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INTRODUCTION TO STAAD PRO 

ENGINEERING STRUCTURE AND STRUCTURAL DESIGN: 

An engineering structure is an assembly of members or elements transferring the load or resisting external 

actions and providing a form to serve the desired function. 

The structural design is a science and art of designing with economy and elegance. A durable structure, 

which can safely carry the forces and can serve the desired function satisfactorily during its expected 

service life span.  

OBJECT AND BASIC REQUIREMENTS OF STRUCTURAL DESIGN : 

➢ Serviceability 

➢ Safety 

➢ Durability 

➢ Economy 

➢ Aesthetic beauty 

SEQUENCE OF STRUCTURAL DESIGN:  

• Design of Slab 

• Design of Beam 

• Design of Column 

• Design of Footiong 

• Design of Staircase 

 

 

 

Design Process: 
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Engineering is a professional art of applying the science to the efficient conversion of natural resources for 

the benefit of man. Engineering, therefore, requires above all creative imagination to innovate useful 

application for natural phenomenon. 

The Design of any structure is categorized into two types: 

1) Functional Design 

 2) Structural Design 

1) Functional Design:  

The structure to be constructed should primarily serve the basic purpose for which it is to be used and must 

have a pleasing look. 

The following factors comes under Functional Design Whether the structure should be a load bearing 

structure or RCC framed structure or a steel structure, whether the roof shall consist of steel roof trusses 

and girders or RCC folded plates or a RC beam slab construction, Arrangement of rooms, good ventilation, 

lighting, acoustics, sufficient head room, proper water supply and drainage etc. 

2) Structural Design:  

Once the form of the structure is selected the structural design process starts. 

Structural Design is an art and science of understanding the behaviour of structural members subjected to 

loads and designing them with economy and elegance to give a safe, serviceable and durable structure. 
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The principal elements of a RC building frame consists of: 

1) Slab to cover a larger area 

2) Beams to support slabs and walls 

3) Columns to support beams 

4) Footing to distribute concentrated column loads over a larger area of the supporting soil such that 

the bearing capacity of soil is not exceeded. 

In a framed structure the load is transferred from slab to beam, from beam to column and then to foundation 

and soil below it. 

 

Stages in STRUCTURAL DESIGN: 

The process of structural design involves the following stages: 

1) Structural Planning 

2) Action of forces and Computation of loads 

3) Methods of Analysis 

4) Member design 

5) Detailing, Drawing and Preparation of schedules. 
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STRUCTURAL PLANNING 

After getting an architectural plan of the buildings, the structural planning of the building frame is done. 

This involves determination of the following: 

(a) Positioning and Orientation of Columns 

(b) Positioning of Beams. 

(c) Spanning of Slabs. 

(d) Layout of Stairs 

(e) Selecting proper type of Footing. 

The basic principle in deciding the layout of component members is that the loads should be transferred to 

the foundation along the shortest path. 

Positioning and Orientation of Columns: 

Following are some of the guiding principles which help in deciding the column positions 

(1) Columns should preferably be located at or near the corners of a building, and at the intersections of 

beams/walls:  

The positioning of columns at the intersection of walls and at the comers of a building is shown in Fig. 

Since the basic function of the columns is to support beams which are normally placed under the walls to 

support them, their position automatically gets fixed as shown in the figure. The commercial buildings have 

normally rectangular pattern of grid type shown in the figure but especially for residential buildings the 

said type of pattern for columns does not become possible and different problems that arise are discussed 

further. 
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2) Select the position of columns so as to reduce bending moments in beams: 

When the locations of two columns are very near (eg. as it occurs when the corner of a building and the 

point of intersection of walls come very close to each other), then one column should be provided instead 

of two at such a position so as to reduce the beam moment. 

 

 

(3) Avoid larger spans of beams. 

When the centre to centre distance between the intersection of walls is large or where there are no cross 

walls, the spacing between two columns is governed by limitations on spans of supported beams, because 

spacing of columns decides the span of the beam. As the span (and the length) of the beam increases, the 

required depth of the beam, and hence its self-weight, and the total load on beam increases. 

 

(4) Avoid larger centre to centre distance between columns: 

It increases the span and cost of beams and in turn increases the load on the column at each 

floor. 
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(5) Columns on property line: 

Shift the column inside along a cross wall or adopt a combined footing or a strap footing. 

 

Orientation of Columns: 

(1) Avoid projection of column outside wall: 

When the thickness of wall is less than the width of column adopt a T shaped column at junctions or L 

shaped column at corners. 

(2) Orient the column so that the depth of the column is contained in the major plane of bending or is 

perpendicular to the major axis of bending. 

Increasing the depth of the column in the plane of bending not only increases the moment carrying 

capacity but also increases its stiffness, thereby more moment is transferred to the column at the beam 

column junction.  

If the difference in bending moment in two mutually perpendicular directions is not large, the depth of the 

column may be taken along the wall, provided column has sufficient strength in the plane of large moment. 



13 
 

 

Positioning of beams: 

(1) Beams shall be provided under the walls or below a heavy concentrated load to avoid these loads directly 

coming on the slabs. 

The maximum spacing of beams may be limited to the values of maximum spans of slabs given below(for 

a LL < 5KPa) 

 

(2) Avoid larger spacing of beams from deflection and cracking criteria. 

Deflection varies directly with the cube of the span and inversely with the cube of the depth i.e L3/D3. 

Hence increase in depth D is less than increase in span L which results in greater deflection for large span. 

 

Spanning of Slabs: 

It depends on the type of slab i.e., when the supports are only on opposite edges or only in one direction, 

then the slab acts as a one way supported slab. 

When the rectangular slab is supported along its four edges, it acts as a one way slab when Ly/Lx is >2 and 

as two way slab for Ly/Lx < 2. 
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Note: A two way slab is generally economical compared to one way slab because steel along both the spans 

acts as main steel and transfers the load to all its four supports. 
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INTRODUCTION TO ETABS 

ETABS is an engineering software product that caters to multi-story building analysis and design. Modelling 

tools and templates, code-based load prescriptions, analysis methods and solution techniques, all coordinate with the 

grid-like geometry unique to this class of structure. Basic or advanced systems under static or dynamic conditions 

may be evaluated using ETABS. For a sophisticated assessment of seismic performance, modal and direct-integration 

time-history analyses may couple with P-Delta and Large Displacement effects.  

Nonlinear links and concentrated PMM or fiber hinges may capture material nonlinearity under monotonic 

or hysteretic behaviour. Intuitive and integrated features make applications of any complexity practical to implement. 

Interoperability with a series of design and documentation platforms makes ETABS a coordinated and productive 

tool for designs which range from simple 2D frames to elaborate modern high-rises. 

MODELLING OF STRUCTURAL SYSTEMS 

Fundamental to ETABS modelling is the generalization that multi-story buildings typically consist of identical or 

similar floor plans that repeat in the vertical direction. Modelling features that streamline analytical-model 

generation, and simulate advanced seismic systems, are listed as follows: 

• Templates for global-system and local-element modelling 

• Customized section geometry and constitutive behaviour 

• Grouping of frame and shell objects 

• Link assignment for modelling isolators, dampers, and other advanced seismic systems 

• Nonlinear hinge specification 

• Automatic meshing with manual options 

• Editing and assignment features for plan, elevation, and 3D views 

 

 

 

 LOADING, ANALYSIS, AND DESIGN 

Once modelling is complete, ETABS automatically generates and assigns code-based loading conditions for 

gravity, seismic, wind, and thermal forces. Users may specify an unlimited number of load cases and combinations. 

https://wiki.csiamerica.com/display/kb/Material+nonlinearity
https://wiki.csiamerica.com/display/kb/Frame
https://wiki.csiamerica.com/display/kb/Shell
https://wiki.csiamerica.com/display/kb/Link
https://wiki.csiamerica.com/display/kb/Hinge
https://wiki.csiamerica.com/display/kb/Discretization
https://wiki.csiamerica.com/display/kb/Load+case
https://wiki.csiamerica.com/display/kb/Load+combination
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Analysis capabilities then offer advanced nonlinear methods for characterization of static-pushover and dynamic 

response. Dynamic considerations may include modal, response-spectrum, or time-history analysis. P-delta effect 

account for geometric nonlinearity. 

Given enveloping specification, design features will automatically size elements and systems, design reinforcing 

schemes, and otherwise optimize the structure according to desired performance measures. 

 

OUTPUT, INTEROPERABILITY, AND VERSATILITY 

Output and display formats are also practical and intuitive. Moment, shear, and axial force diagrams, presented in 

2D and 3D views with corresponding data sets, may be organized into customizable reports. Also available are 

detailed section cuts depicting various local response measures. Global perspectives depicting static displaced 

configurations or video animations of time-history response are available as well. 

ETABS also features interoperability with related software products, providing for the import of architectural 

models from various technical drawing software, or export to various platforms and file formats. SAFE, the floor 

and foundation slab design software with post-tensioning (PT) capability, is one such option for 

export. CSI coordinated SAFE to be used in conjunction with ETABS such that engineers could more thoroughly 

detail, analyse, and design the individual levels of an ETABS model. 

While ETABS features a variety of sophisticated capabilities, the software is equally useful for designing basic 

systems. ETABS is the practical choice for all grid-like applications ranging from simple 2D frames to the most 

complex high rises. 

 

https://wiki.csiamerica.com/display/kb/Modal+analysis
https://wiki.csiamerica.com/display/kb/Response-spectrum+analysis
https://wiki.csiamerica.com/display/kb/Time-history+analysis
https://wiki.csiamerica.com/display/kb/P-Delta+effect
https://wiki.csiamerica.com/display/safe/Home
https://wiki.csiamerica.com/display/kb/Tendon
http://www.csiberkeley.com/
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BASIC MODES, DRAWING TOOLS, MOUSE POINTERS  

Select or Draw 

  

Quick Model Template Forum  

Grid Dimensions (Plan) - Define a Grid System Use the Grid Dimensions (Plan) area of the form to define a grid 

line system. Select from two options for defining the grid line system: 

 Uniform Grid Spacing. Specify the number of grid lines in the X and Y directions and a uniform spacing for those 

lines. Note that the uniform spacing in the X and Y directions can be different. This option defines a grid system for 

the global coordinate system only. Click the Grid Labels button to control how the grids are labelled. If subsequently 

necessary, edit the information using the Edit menu > Edit Stories and Grid Systems command.  

Custom Grid Spacing. Define non uniformly spaced grid lines in the X and Y directions for the global coordinate 

system. After choosing this option, click the Edit Grid Data button to edit the grid system. 
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STORY DIMENSIONS 

DEFINE STORY DATA  

Use the Story Dimensions area of the form to define the number and height of stories. Select from two options for 

defining the story data:  

 Simple Story Data: Enter values in the edit boxes to define the number of stories and a typical story height that is 

used for all story levels except for the bottom story, which is specified separately. The program provides default 

names for each story level (for example, Story1, Story2 and so on) and assumptions for story level similarity. 

  Custom Story Data: After choosing this option, click the Edit Story Data button to access the Story Data form. 

Enter values in the Story Data form to define your own story names, story levels of non-uniform height and 

customized story similarity. Story level "similarity" can be significant, e.g., when Story2 is a Master Story, and Story1 

is similar to Story2, an object drawn on Story2 typically appears in the same 

CREATE THE STRUCTURAL MODEL 

 

MATERIAL PROPERTIES  

Click the Define menu > Material Properties command to display the Define Materials form or under the Model tab 

on the Model Explorer expand the Properties branch and then the Materials branch to see a list of the defined material 
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properties (a right-click on the Materials branch will display a context sensitive menu). The Define Materials form 

allows for the both the review of existing materials, as well as the definition of new properties. To add a new material, 

click the Add New Material button on the Define Materials form. When the Add New Material Property form appears 

as shown in Figure 5-4, select a material from the Material Type drop-down list and then a Standard and Grade from 

their respective drop-down lists. 

 

FRAME SECTIONS 

 Click the Define menu > Section Properties > Frame Sections command, which will display the Frame Properties 

form. The Frame Properties form allows for the definition of new sections as well as the review of existing sections. 

To make steel frame sections from property files available click the Import New Properties button, or to add user 

defined sections click the Add New Property button, both of which will display the Frame Property Shape Type form. 

 

 

ASSIGNING THE PROPERTIES 

In creating the model, the user draws joint, frame, shell, link, and tendon objects. To enable analysis and design, 

those objects must be assigned properties, such as material properties, frame sections, wall/slab/deck sections, link 

properties, tendon properties, and loads, among others. Note that the assign menu lists the various properties that can 

be assigned.  
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STRUCTURAL LOADS 

 The program allows the user to define a variety of structural loads, including dead, live, earthquake and wind loads. 

The user then assigns the loads to various structural objects in the model. An unlimited number of load patterns can 

be defined. Note that the steel frame, concrete frame, composite beam, composite column, steel joist, concrete shear 

wall, concrete slab, and steel connection design manuals describe design combinations in accordance with building 

codes. 

DEFINE THE LOAD PATTERNS  

To add a load pattern, click the Define menu > Load Patterns command or expand the tree on the Model tab in the 

Model Explorer and right click on Load Patterns to access the Define Load Patterns form. Complete the following 

actions using that form:  

1. Type the name of the load pattern in the Load edit box. The program does not allow use of duplicate names.  

2. Select a load type from the Type drop-down list.  

3. Type a self-weight multiplier in the Self-Weight Multiplier edit box (see the explanation about the self-

weight multiplier that follows).  

4. If the load type specified is Seismic or Wind, select an option from the Auto Lateral Load drop-down list.  

5. Click the Add New Load button. 

REVIEW/CREATE LOAD CASES  

A load case defines how loads are to be applied to the structure, and how the structural response is to be calculated. 

Analyses are classified in the broad sense as either linear or nonlinear, depending on how the model responds to the 

loading. The results of linear analyses may be superposed, i.e., added together after analysis. The results of nonlinear 

analyses normally should not be superposed. Instead, all loads acting together on the structure should be combined 

directly within the nonlinear load case. After all geometry and load input has been specified for a model, review, 

modify, or add load cases using the Define menu > Load Cases command. load case (ETABS automatically generates 

a load case for each load pattern defined) and click the Modify/Show Case button to review or modify the load case 

definition. Click the Delete Case button to delete the highlighted load case. 
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SET THE MESH OPTIONS 

 If your model contains wall objects, or floor objects that have plate bending behaviour such as cast-in-place slabs, 

review the meshing options (e.g., maximum mesh size) before running the analysis by using the Analyze menu > 

Automatic Mesh Settings for Floors or Analyze menu > Automatic Rectangular Mesh Settings for Walls commands. 

The Automatic Mesh Options (for Floors) form is shown in Figure 11-1. Default mesh settings for floors and walls 

may be reviewed by using the Assign menu > Shell > Floor Auto Mesh Options and the Assign menu > Shell > Wall 

Auto Mesh Options commands, respectively. 
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MODEL ANALYSIS  

Prior to running the analysis, verify what load cases are set to run by clicking on the Analyze menu > Set Load Cases 

To Run command. The Set Load Cases to Run form. To add or remove a load case from the analysis, highlight the 

load case in the Case column and click the Run/Do Not Run Case button. Both the status and action for each case are 

shown in their respective columns. This form also allows the user to set how the Analysis Monitor should be displayed 

- the default setting is that it Never Shows. 

To run the analysis, click the Run Now button if the Set Load Cases to Run form is still displayed, otherwise click 

the Analyze menu > Run Analysis command or the Run Analysis button, . The program will display an "Analysing, 

Please Wait" window if the Analysis Monitor has been set to "Always Show" or "Show After." Data will scroll in 

this window as the program runs the analysis. After the analysis has been completed, the program performs a few 

more “bookkeeping actions” that are evident on the status bar in the bottom left-hand corner of the ETABS window 

LOCKING AND UNLOCKING THE MODEL  

When the entire analysis process has been completed, the model automatically displays a deformed shape view of 

the model, and the model is locked. The model is locked when the Lock/Unlock Model button, appears closed. 

Locking the model prevents any changes to the model that would invalidate the analysis results. 

DESIGN THE STRUCTURE  

The ETABS design postprocessors include the following: 

• Steel Frame Design 

• Concrete Frame Design  

• Composite Beam Design 

• Composite Column Design 

• Steel Joist Design  

•  Shear Wall Design  
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•  Concrete Slab Design  

•  Steel Connection Design  
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To perform the design, first run the analysis then click the Design menu and select the appropriate design from the 

drop-down menu. The type of design available depends on the type of members used in the model. That is, the user 

cannot complete a shear wall design if no shear walls have been included in the model, nor could they do a steel 

connection design if no steel members are present. Similarly, the commands used to execute a design depend on 

the type of design to be performed. However, each design has commands to address the following: 

 Review and/or select overwrites. 

  Review and/or select design combinations.  

 Start the design or check of the structure.  

 Perform interactive design.  

 Display input and output design information on the model. 

DETAILING PROCESS  

ETABS detailing generates two basic types of drawing output:  

 Drawing sheet component views of detailed objects, such as steel beam framing plans, steel column schedules, 

concrete beam elevations and sections, concrete column schedules, shear wall reinforcing sections and elevations, and 

steel connection tables  

 Drawing sheets containing the selected component views 
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1a. MODELLING OF THE GIVEN STRUCTURE USING STAAD PRO 

Aim: 

To model the given structure using STAAD pro 

Software Used:  

STAAD Pro  

 

Layout of the 

building 

 

 

Defining the 

dimensions 

of the 

building  
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Model of the 

building 

 

     

 

 

Defining 

primary loads 

 

 

 

 

 

Defining 

supports 
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1b. Modelling of the given structure using ETABS 

Aim: 

To model the given structure using etabs 

Software used:  

Etabs  

 

 

 

 

 

 

 

 plan of the 

model 

 

 

 

 

 

Storey data 
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Modelling  of the given 

plan 
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2a. MODEL TESTING FOR FRAMES 

Aim: 

To test the frames of models of the given structure using STAAD pro 

Software Used:  

STAAD Pro  

 

 

 

 

 

 

 

Properties for the frame 
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Assigning the member 

property 

 

 

 

 

 

Building with plates 
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Creating support 

 

 

 

 

 

 

 

 

 

 

STAAD  analysis 
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Shear bending of the member  

 

 

 

 

 

 

 

 

 

Deflection of the member  
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2b. Model testing for frames using ETABS 

Aim: 

To model the given structure using etabs 

Software used:  

Etabs  

 

 

 

 

 

 

Model of the 

plan 

 

 

 

 

 

 

 

Column 

property 
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Beam properties 

 

 

 

 

 

 

 

 

 

 

 

 

 

After assigning 

the loads 
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Analysis of the 

building  

  

 

 

 

 

 

 

 

Deflection 

After loadings 
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3A. MODEL TESTING OF FRAMES UNDER STATIC LOADING 

 

Aim: 

To test the frames of models of the given structure under static loading using STAAD pro 

Software Used:  

STAAD Pro  

 

 

 

 

 

 

 

 

 

Loads and 

Defination  
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Wall loadings 

 

 

 

 

 

 

 

 

Bending moment 

in the members of 

the building 
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Shear force in the 

members of the 

building 

 

 

 

 

 

 

 

 

 

 

 

 

Support reactions 
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3b. Model testing on frames under static loading 

 

Aim: 

To model the frames under static loading for given structure using etabs 

Software used:  

Etabs  

 

 

 

 

 

 

 

Plan of the model 

 

 

 

 

Defining load 

patterns 

 

 

 



40 
 

 

 

 

 

 

 

 

 

Shell loading 

assignment 

 

 

 

 

 

 

 

 

 

Assigning slab 

loads  
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Loadings on 

frame 

 

 

 

 

 

 

 

 

 

Beam loads 
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Support 

reaction 

along a 

section 

 

 

 

 

 

 

Bending 

stress on the 

floor  
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Bending 

moments on 

the floor 

 

 

 

 

 

 

Shear force 

on the floor 
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4A. MODEL TESTING OF FRAMES UNDER DYNAMIC LOADING 

Aim: 

To test the frames of model of the given structure under dynamic loading using STAAD pro 

Software Used:  

STAAD Pro  

 

 

 

 

 

 

Seismic loading 

 

 

 

 

 

 

 

 

Seismic 

definitions 
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Bending 

moment in the 

members of the 

building 

 

 

 

 

 

 

 

 

 

Deflection of 

the members 
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Shear forceof 

the members 
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4b. Model testing of frame under dynamic loading  

Aim: 

To model the frame under dynamic loading for given structure using etabs 

Software used:  

Etabs  

 

 

 

Loadings 

 

 

 

 

 

 

 

Assigning of seismic load 
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Loading on frame 

 

 

 

 

 

 

 

Assigning of wind load 
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5A. MODEL TESTING OF SHEAR WALL UNDER LATERAL LOADS 

Aim: 

To test the model of shear wall under lateral loads using STAAD pro 

Software Used:  

STAAD Pro  

 

 

 

 

 

 

 

 

Model of the shear wall building 

 

 

 

 

 

 

 

Member property of building  
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Winds and seismic 

Load definitions  

 

 

 

 

 

 

 

 

Loading data 

Of earthquake 

loads, wind loads 

and load 

combinations 
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Loading data 

Of loading 

combinations 

 

 

 

 

 

Loading data 

Of loading 

combinations 
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Loading data 

Of loading 

combinations 

 

 

 

 

 

 

 

Positioning of 

shear wall 
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Displacements 

obtained due to 

loading 
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5b. Model testing of shear wall under lateral loads 

Aim: 

To model shear wall under lateral loads for given structure using etabs 

Software used:  

Etabs  

 

 

 

 

 

 

Plan of the 

given 

building 

 

 

 

 

 

Defining 

material 

property 

 



55 
 

 

 

 

Shear walls on 

the model 

 

 

 

 

 

 

Load 

combinations 
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Load 

combinations 

 

 

 

 

 

 

Load 

combinations 
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Reactions at 

supports 

 

 

 

Reactions at 

supports 

 b. M.  
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Shear force  
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6A. MODEL TESTING OF SHELLS, PLATES UNDER STATIC LOADING. 

 

Aim: 

To test the model of shells , plates under static loading using STAAD pro 

Software Used:  

STAAD Pro  

           

 

 

 

 

 

 

Model of a shell 

 

    

 

 

 

 

 

 

 

Modelling of the 

Shell with plate 

thickness 
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Loads 

 

 

 

 

 

 

 

Assigning of 

load 
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Reactions at the 

supports 

 

 

 

 

 

 

 

 

 

 

Bending 

moment of the 

plates in the 

shell 
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Shear force of 

the plates in the 

shell 

 


